Amiga hardware info, help and support with a focus (but not limited to) North American NTSC experiences. Open to all.
User avatar

by 8bitSheep posted Thu May 30, 2019 5:24 am

Hello all,

I am hoping some of you more experienced Amiga users can help diagnose what I think may be a hardware problem with my Amiga 600.

One of the main things I use my Amiga for is as a serial terminal for my OpenBSD PC (the machines are connected via standard null modem cable). I have been using Term 4.8 as my Terminal software since I first got the Amiga a year and a bit ago and everything has been working well. However just recently I stopped being able to receive data from the PC to the Amiga. I verified that key presses on the Amiga were received at the PC but the key press echos (and responses to executed commands) are never displayed on the Terminal screen.

A google search led to a post that suggested that it could be the CIA chip at fault and to try swapping them. Of course in the A600 that is not really possible as they are not socketed (as far as I know). Another suggestion was to turn off hardware flow control on both machines and see if anything is received. When I tried that I almost immediately got a Guru Meditation error when I tried to start my Terminal program (I forgot the exact error number but google said it was a memory error). I also sometimes get the same error with hardware flow control enable when I try to close the terminal software.

For most of the time with my Amiga I have been running Amiga OS 2.1 but I did upgrade to 3.1.4 at the beginning of the year (a new physical ROM along with a fresh install of the new OS).

My A600 has A604n and A6095 memory extensions. I have tried temporarily removing the A6095 (it is an extension that sits on top of the CPU so I thought it could be a bad connection causing the memory error) but the error persists. Also, apart from the serial connection problem the Amiga seems to be working fine so if it was a general problem with memory I would expect other applications to crash as they tried to use the RAM.

So, from that description does it sound like the CIA chip has gone bad or something else? Is there anything else I can try? Is there any other information that I could provide to help analyse the problem?

Thanks in advance for any help.

User avatar
Springfield, MO

by EzdineG posted Thu May 30, 2019 6:18 am

I have been able to reproduce the guru errors while turning on / off hardware flow control and swapping polarity in terminal on my working A600 w wifi232. Not the exact same configuration as you, but enough for me to think the issue isnt related to your problem.

I have had CIA chips “fail” in an A600 that could temporarily be fixed by putting pressure on the chip and attempting to reproduce the problem (in my case floppy drives not being detected.) The permanent fix was reflowing the chip.

Look at the board and see if there are any obvious marks on any of the resistors by the connector. Have a look at the schematics to see which of those are directly responsible for that pin.
User avatar

by 8bitSheep posted Fri May 31, 2019 2:55 pm

Hello EzdineG,

Thanks for the response and the information, that is exactly the sort of details I was hoping to get. I had read that the CIA chips are a little fragile so had not considered that it may be just connection between the chip and the board. I will take the board out this weekend and do an inspection (after I google for the schematics) and see what I can see.

I did speak to a colleague today who is willing to do the reflow of chip(s) if it looks like that is the problem so that is great :D

I will let you know what happens.

Thanks again!


Who is online

Users browsing this forum: No registered users and 6 guests