Amiga hardware info, help and support with a focus (but not limited to) North American NTSC experiences. Open to all.
User avatar
intric8
Seattle, WA, USA

by intric8 posted Thu Mar 15, 2018 3:23 pm

While having recently finished Dungeon Master - a deeply satisfying personal accomplishment - I’ve been pulling back from intense gaming for a few days. I am playing a new game, which I’ll talk about more later, but suffice to say it's nice to work on the machines sometimes. I feel like half the time my experiments fail. But even when they do, I feel I walk away with a better understanding of the machines which is always a rewarding feeling.

I moved my pristine stock A1000 to a rack for the moment and brought the Phoenix back out again. As some of you may recall, I got really far with it before finally getting frustrated by - of all things - the floppy drive. I customized the original floppy’s bracket to accept a “brand new” floppy drive with an (ug-ly!) 3D printed eject button. I had to make this swap because the original FDD that came with the 1000 back in 1986 is simply way too vertically thick to fit above the Phoenix motherboard with populated KS ROMs. The new drive gave me an obscene amount of room.
IMG_4147.jpg
Bracket holes I added to the original FDD bracket to accommodate the new drive. Note how much higher they are compared to the original holes. That clearance is more than enough.


But I keep having this recurring issue with the floppy that has prevented me from putting the top case on and making the machine a daily driver.

Originally I had difficulty putting the disk in. I could see by looking directly into the FDD disk bay that my original holes were out of alignment ever so slightly. As such the left side was slightly drooping down. So I pulled the bracket out, and the drive from the bracket, and used a grinder to relocate the holes a few millimeters.

Now the drive appears to be perfectly aligned! Yes!

After putting it all back together, I can put a floppy disk in the drive and it goes in smoothly and easily ejects. Everything appears perfect.
IMG_4154.jpg
She's looking mighty fine! And yes that's my Phoenix being worked on above my laundry machines. The height and lighting is actually a bit more comfortable sometimes. The only downside is I don't have a chair in that room. We do have a tiny child's chair, though, that we use when folding clothes. Too short to sit in while working, though.


However. . .

Once I put on the front plastic cover for the FDD - the front part of the 1000’s case - and fire up the power, I can put the disk in just fine but the drive just sits there. For some reason it won’t seek the disk. In fact I can even still hear the repeating sound “clunk. clunk. clunk.” So something isn’t engaging for some reason. But as soon as I pull the front cover off, voila! The disk spins right up and everything works perfectly. Something about that front cover is preventing the disk from being recognized under normal circumstances. Total head scratcher.
IMG_4150.jpg
That's me with a scrunchy face after the buttoning up the whole machine and the FDD not seeing the inserted disk (which goes in and ejects perfectly). WTF?!


If I could figure that out (I’m going to try again tonight) the machine will be good enough to use regularly. The only aesthetic bits that really remain are the eject button and soldering up a new LED for the FDD.

I went ahead and started sanding the giant chicklet.
IMG_4149.jpg
The 'chicklet' still needs work, but at least it doesn't have that awful 3D print tracking anymore. And the front is now smooth and the corners rounded. Just a little more work and it should be good.


I have the correct paint for it and just need to waggle the button loose so I can paint it up. Hopefully I don’t break it when I try to remove it! That would suck.

So close to glory.
User avatar
leighb2282

by leighb2282 posted Thu Mar 15, 2018 3:40 pm

The only thing I can think of is there some part of the front panel that the floppy is getting stuck on and not fully 'dropping' when it enters? beyond something like that there really shouldn't be anything that the front panel interferes with that should cause something this weird from happening.
User avatar
intric8
Seattle, WA, USA

by intric8 posted Thu Mar 15, 2018 3:49 pm

Yeah, it's really weird. I mean maybe the button is getting some really slight pressure on it from the case? I don't know. I'll keep whittling it down. It's a strange (and aggravating) problem.

Tempted to remove the button entirely, which I'll need to do anyway to paint it, and see if the problem goes away.
User avatar
McTrinsic

by McTrinsic posted Fri Mar 16, 2018 2:33 pm

It could be that your cage is protruding a bit too much to the front, even if only a tiny amount.
In the last step of the insertion process the disk goes down a mm or two afaik. It could be that the disk will not move down fully because it collides with the plastic cover.

But man this is frustrating I know. I have been through my ups and downs with my little diva as well.

Just remember it's worth it and will be sooo rewarding in the end :D .
User avatar
intric8
Seattle, WA, USA

by intric8 posted Fri Mar 16, 2018 3:07 pm

@McTrinsic, if that is indeed the case, would you drill the mounting screws a few mm towards the back of the machine, to push the drive back ever so slightly (maybe 1mm)? I wouldn't want to go too far as right now when there is no disk inserted the eject button looks perfect flush with the front case, which visually looks right. But I could push it back a tiny bit I think.

I'm going to try and remove the button this weekend and see if there's a change just from doing that. I'm really nervous it might break, but I've nothing to lose at this stage. If it does break I can always order another button.
IMG_4151.jpg
User avatar
intric8
Seattle, WA, USA

by intric8 posted Fri Mar 16, 2018 6:38 pm

UPDATE:
I successfully removed the giant FDD button without breaking it. After that I put the case back on and set a monitor on top.

Powered it on.

FDD works brilliantly now! Something about mild pressure on the button is preventing it from being read. So the issue revolves around the stinking button! Now that I know the problem I can attack it.

Progress!
User avatar
Zippy Zapp
CA, USA

by Zippy Zapp posted Fri Mar 16, 2018 11:37 pm

Glad you figured it out. From the picture above it looks like the button could be rubbing on the case on the left. If it is getting hung up on the case I guess that could do it too.
User avatar
intric8
Seattle, WA, USA

by intric8 posted Mon Mar 19, 2018 8:44 am

I have some excellent news to report! I've finally gotten the FDD to work perfectly on the Phoenix. Finally!

It required me to re-grind the internal bracket a third (4th?) time so that I could push the drive aft about 3- millimeters. There was some sort of very slight touch between the inserted disk and the front case cover.

As such, the 3D printed button now doesn't stick out quite as far as it should. It works, and I can eject disks. But when the computer has no disk inserted, the button is obviously recessed inside the case. When you insert the disk, it is sticking out about 3mm. Ideally it would be 5-6 so you could give it a more natural and solid push.

So.

I've contacted Amigastore.eu to see if they'd let me get a copy of their button's STL file. If I can get ahold of that, I should be able to extrude the button in a 3D modelling program and have the button reprinted (somewhere? Probably shapeways.com).

Then I can swap buttons and go from there. But at least the damn thing works now!

To celebrate, I popped the Jim Drew WiFi modem into its back serial port (facing down of course, due to the 1000's gender changer) and hit ParticlesBBS to announce the victory. :)

Next up for the Phoenix while I wait on buttony stuff: to create a brand new design for the Phoenix front cover sticker. And those I'll probably plop on a1k.org later, too, for a couple of folks that might want one.
User avatar
intric8
Seattle, WA, USA

by intric8 posted Mon Mar 19, 2018 8:51 am

While I'm waiting to hear back from Amigastore.eu, if anyone sees a 3D printed mock of this (I believe) A500 button in question, please let me know.
button.png


There is a similar looking one on Thingverse, but it's not exactly the same and I get the feeling wouldn't fit.
User avatar
Shot97
Detroit, MI, USA

by Shot97 posted Mon Mar 19, 2018 2:30 pm

I looked for you; But couldn't find my old floppy drives. Found some other old goodies, though.

Image

Who is online

Users browsing this forum: No registered users and 1 guest