Amiga hardware info, help and support with a focus (but not limited to) North American NTSC experiences. Open to all.
User avatar
In_focus

by In_focus posted Wed Jan 23, 2019 7:28 am

Before Xmas I brought out of retirement an old Amiga 500+ from the attic. It had been up there for a number of years and had succumbed to usual NiCad leak, cleaning up and a repair to the FDD got it up and running and my 4yr old grandson absolutely loves it. Unfortunately time has taken it's toll on the floppies and a high proportion no longer work so a Gotek emulator was purchased. This has given the machine a new lease of life but I have problems with a couple of games which to me look like some form of memory issue.

Two titles affected are Arabian Knight (my personal favourite) and Fire & Ice which have graphics issues. From the pics below can anyone confirm if this is indeed memory related or possibly some issue with Fat Agnus? I must add that the original floppy based version which were still working and showed the same problem so it doesn't appear to be associated with the Gotek. We have two Amigas and still have the original A500 to look at but I don't think the above titles ever worked correctly on the A500+.

Can anyone suggest any memory tests?
rsz_fire_&_ice.jpg
User avatar
EzdineG
Springfield, MO

by EzdineG posted Wed Jan 23, 2019 11:15 am

Go here and download the latest build of Keir Fraser's systest. You can get either the executable or a bootable ADF from that link which will run a thorough memory test.

I don't know if perhaps you're seeing a PAL/NTSC timing issue with those particular games or if it is indeed a memory issue, but the memory test is really easy to get out of the way with Keir's systest.

Good luck!
User avatar
In_focus

by In_focus posted Sun Jan 27, 2019 6:31 am

Well I've tried that and no memory errors are reported so maybe it is a Fat Agnus problem. BTW the machine and games are definitely PAL 50Hz.

A question about Fat Agnus compatibility, my original non working A500 has an 8372A fitted whereas the + has an 8375. I've tried swapping them but with the 8372A in the + it doesn't boot, just a black screen. The 8375 in the A500 gives 10 flashes on the keyboard.

Another question if I may, is it possible to get a + to run at 500k memory, I'm led to believe it's possible with changing a jumper pad on the board? The reason for asking is Bubble Bobble.
User avatar
TommyE

by TommyE posted Sat Feb 16, 2019 2:53 pm

In_focus wrote:Well I've tried that and no memory errors are reported so maybe it is a Fat Agnus problem. BTW the machine and games are definitely PAL 50Hz.

A question about Fat Agnus compatibility, my original non working A500 has an 8372A fitted whereas the + has an 8375. I've tried swapping them but with the 8372A in the + it doesn't boot, just a black screen. The 8375 in the A500 gives 10 flashes on the keyboard.

Another question if I may, is it possible to get a + to run at 500k memory, I'm led to believe it's possible with changing a jumper pad on the board? The reason for asking is Bubble Bobble.



Hello

Dont know so much about the graphics problem, but you will not be able to switch the Agnuses like that, they are not pin compatible.

Regards
tommy

Who is online

Users browsing this forum: nonarkitten and 1 guest