User avatar
Seattle, WA, USA

Posted Tue Nov 21, 2017 2:12 pm

Short video of my launching 64Door from my hard drive and cruising a few of my favorite PETSCII BBSes.

Ever since I got my Amigas online using one of Paul Rickards’ fantastic WiFi232 modems, I’ve been using the wonderful terminal program for Amigas called 64Door as one of my main go-to programs to connect. 64Door is an awesome way to connect to BBSes that run off of C64s or C128s as it fully supports PETSCII mode. Thus, all of the screens and menus render exactly as they would if you were connecting with a C64. And I discovered you can install it to a hard drive under the right conditions.

64Door doesn’t allow directory or file transfers but it does provide near-perfect 40 or 80 column PETSCII.

Whenever I hit non-PETSCII boards, I use A-Talk III made by Oxxi Software. A-Talk III is very user-friendly, customizable, and (drum roll) hard drive installable. It was simply made for Workbench and renders ANSI and other sites beautifully. The only “down side” is that it uses its own color palette. This is both a pro and a con. The con is that you never see the BBS you hit in the sysop’s original color palette. The pro is that by choosing your own colors you can make it exactly the way you prefer for your own legibility and aesthetics.

With 64Door, you get what was originally designed exactly as it was intended for you to see. For C64 BBSes, you tap the ‘Help’ key on your Amiga keyboard and switch to 40 column mode. This makes the fonts fill your screen and look nice and chunky like you’re on a Commodore 64. For “fancier” boards, which support 40 or 80 column mode, you can keep it in the default mode of 80 columns. This obviously allows for much more text on the screen.

In 64Door, one quirk before connecting is to make sure you tap ‘Help’ and switch to 9600 baud or the Qwerty keys won’t work. Once you do make the switch and flip back to the terminal window everything works perfectly.

Well, almost.

For some reason potentially unique to connecting with modern WiFi devices, you have to error-out the terminal first. This is done by typing anything (I typically just hit the spacebar once) and then hitting ‘Return’. This will make the terminal spit back ‘Error’ and at this point you can type in your addresses.


Code: Select all

In any case, for all this time 64Door is where I start nearly every night. It’s only other quirk is that it requires to be booted via floppy. As long as I’ve had the program I’d heard it wasn’t hard drive installable, which isn’t a huge deal - a lot of early software was like this - but it was something.

Last night I ran across a thread of two of my online friends lamenting this issue again. They were combined with photos of a screen that looked to have some sort of strange video display issue.

I thought, “What the heck. Let’s try it.”

I fired up my 2000 running WB 1.3, then launched Directory Opus 4. I inserted 64Door into the floppy drive and copied the entire contents over to one of my drives - all of it, including the WB files (probably not necessary, but figured who cares?). Lastly, I used DOpus to ‘Add Icon’ to the 64Door executable.
I lazily then went to the new directory and double-clicked the newly-created hammer icon.

And lo and behold… 64Door launched instantly!

I couldn’t believe it. All of this time 64Door absolutely could have been running off a hard drive - as long as you were running 1.3!

I quickly related these results to the original thread and some theories & discoveries flowed:
1. There is a library or file native to 1.3 that conflicts with WB versions greater than 1.3.
2. If one is on an AGA machine, and turns AGA off and the screen mode is set to non-interlaced HiRes (640x200) it will start up fine in WB 3.1. Seems to be tied to the screen mode of WB & the chipset (via @paradroyd)
3. Might be an AGA thing (this made me slap myself, as I haven’t been running AGA in over a year).

Bottom line for today, though:
If you aren’t running an AGA machine, and are running 1.3, you absolutely can install 64Door to your hard drive and stop running it off the floppy via boot-up. 1.3 for the win - again! <3

From @mntmn on Twitter:
It runs for me also on 3.9, on an ECS machine. i tried it only from no-startup-sequence CLI yet tho. the WB contents are not needed, only the 64door drawer.

Return to “Software”