The real reason you got that machine (or emulator), right? Classic and new Amiga games talked about here. Have you seen the Games Library?
User avatar
Seattle, WA, USA

by intric8 posted Sat Apr 15, 2017 10:22 am

Upon returning from my trip to Maui this year, I was welcomed by a package containing the “Gold Box” classic Curse of the Azure Bonds by SSI.

Before leaving I knew I wanted to take a deeper dive into the Gold Box games. I had already done a fairly half-assed flyby (meaning: I didn't finish it) of Pool of Radiance (1988) and really liked what I saw. I will have to give it the full deep-dive some day and play it to the end.

What made these games really special at the time was that many had first been books before being translated into games. Not every D&D fan out there is keen on the massive Forgotten Realms arterial setting, but I like it. It is the birthplace of so much great content, including future endeavors across Baldur’s Gate and Neverwinter.

So, before hopping on a plane ride that is close to 6 hours going west (about 5 hours on the return trip, thanks to the jet stream) I downloaded Azure Bonds to my Audible account. I wanted to really get into the D&D mindset before starting the game, and this book was written before the 2nd Edition rules had even been published. So yes, it’s very old-school. The audio book is over 14 hours long, but I was able to get well past the half-way point by the time I got home.

The computer game, which came out a year later in 1989 (as also did a D&D game module) was released right around the same time as 2nd Edition. In fact, advertisements for it could be found in the Gold Box edition of Azure Bonds. Second edition was probably my favorite BITD. I kept playing as my brother was a hard-core dungeon master. In fact, at age 47, he still is and plays via Skype/Facetime every weekend. But I digress…

The Audbile book Azure Bonds is a lot of fun. The woman who reads it to you, Kristin Kalbli, is pretty good as the story progresses. At first she’s a bit robotic. And at times, since there are so many different characters involved, she accidentally blends some of the character voices together (it's subtle, but I picked up on this occasionally). But she does a pretty nice job of setting the right tone even if the story feels a bit like ‘teen fiction” at times. The story itself is actually a bit more surprising at times than I expected it to be. It's not deep by any stretch, but the characters are very interesting as is the relatively fast-moving plot. It makes me want to go get more of these when I’m done (I already know which ones, too!).

In any case, I found the game on Ebay for $14 before I left, and it was waiting for me when I got home after a nice Spring Break. The box is really screwed up, but all of the contents are pristine.

I ultimately installed it, and immediately created my party using the character’s names I had encountered in the book. I can’t wait to dig in!

Nerdy Experience: The HD Installation

Azure Bonds comes on two floppy disks. When you pop in Disk 1, you see the awesome launch icon with the character Alias (that's her name) looking back at you. You also get two icons for HD installs. Interestingly, you can only install to hard drives with the names DH0 or DH1, if you happen to have those.

As some of you might recall, my hard drive IDs are weird. The previous owner (or the Quantum hard drive company itself) decided eons ago to label my hard drives QDH0 and QDH1. I can’t rename the IDs of the partitions without wiping out all of the data. And, so far, it really hasn’t ever affected my use of the Amiga 2000 one bit, other than having to occasionally change a path here or there from the typical defaults.

Anyway, SSI coded the HD installs with paths you couldn’t alter. You only got those two choices. Now, for a brief second there I considered just copying the disks and playing off floppies. Big deal. But then I got to wondering…

My HD IDs are set up like this:

(Quantum drive)
QDHO: “System” boot drive, workbench and system tools; 9MB
QDH1: “Fun” games drive; 40MB
Then I added an 4GB SD micro drive to my SCSI chain a few weeks ago. So, keeping the IDs consistent I created
QDH2: “Flash” additional and future new games drive, 2GB
QDH3: “Ming” I had been planning to use this for productivity software titles, but currently it was empty

No matter what I tried with the Azure Bonds installs, though, I couldn’t get it to work. I couldn’t edit the icons. Actually, they appeared to be batch scripts, so changing the Info really didn’t affect the code being run anyway. Copying all of the files off the disks to HD resulted in broken drive paths when launching the games of HD.

Then I fired up HDInstTools to run an experiment. I went into the Partition Tools and changed Ming’s ID to DH1:

I worried that doing so might confuse the machine on boot, so I really didn’t want to rename it to DH0: where Workbench lives (in QDH0:). Following me so far? But I remembered that the boot priority numbers are what really matter in the SCSI chain, not the names or IDs. And those were good to go no matter what I did. In theory.

I had to do a reboot for the ID reassignment to take place. By doing so, I was warned all of my data would be lost. I didn’t care since that drive was empty.

I took a breath, and rebooted.

And lo and behold, it worked! I was able to rename the ID to the much more common DH1: even though it is the 4th drive in the chain! The order of the drives supersede the IDs. So now my drives look like this:

QDH0: (boot)
QDH1: (orig games)
QDH2: (Flash (he’s a miracle!)
DH1: new games

I think I may actually move the data that is sitting on Flash over to DH1 and rename QDH2 to DH0;

It’ll look like a total clusterfuck to some, but it’ll actually work even though my DH0 is actually storage, not a boot drive.

Crazy, huh?

But, much more importantly, once I clicked on the install icon for Azure Bonds, it saw the new drive and got to work! Boom, shaka-laka!
The manual for Curse of the Azure Bonds, and the awesome launch and HD install icons.

Fantastic launch screen for Azure Bonds, with Alias in the foreground.

Alias' magical (cursed) tattoos, which glow from beneath the skin on her arms. I named several of my characters after the ones found in the book. Don't worry - I quickly found the weapons and armor shop and lowered all of their ACs. Thankfully, the game starts you off with a pile of platinum coins, so equipping your characters (if you don't transfer any from Pool of Radiance, or - interestingly - Hillsfar).
User avatar
Seattle, WA, USA

by intric8 posted Fri Apr 21, 2017 11:54 am

Something odd has happened.

I created my party and played for well over an hour and a half across two sessions. I explored over half of the town of Tillerton and have engaged in multiple fairly large-scale battles. After making out of a fight (barely) I saved and shut things down last night.

This morning, before work, I turned everything back on to do a little last minute adventuring before heading to work. I started to move around the Thieves' Guild, interacted with one NPC, and then the screen froze. I could move the mouse around the screen, but the action was frozen and I couldn't click on anything. The keyboard was unresponsive, too.

I turned the machine off and on again.

I restarted the game and this time while moving around my party got ambushed by Fire Knives. A battle ensued. I was winning pretty easily and then... the screen froze again. I don't believe that the hard drive was being seeked during either time, but I can't be sure for certain. I'd be very surprised if it was, though.

Really odd. Not sure what's going on here.

I will try to do a few more tests tonight, but it's certainly disheartening after getting into the flow of the game to have this happen. I can't really tell if it is hardware or software based (maybe both?). This is the only game I've ever seen this happen before. And, maybe it is related to the HD install. This could be the bug that made SSI decide to go floppy-only. Worst case, I could play off the disks and load my saved game. If the same issue occurs, it would eliminate the HD Install at least. If everything works just fine - then it really is more than a simple "do you have enough RAM" issue. It'd suggest to me that the code simply couldn't copy with the HDD. That would really seem odd to me, though. And how did I play for so long the past two days, only to have this happen within 5-10 minutes of adventuring today. Could it be corrupt data in a particular area from the source disk that got copied (although, it doesn't seem to be in the exact same place each time something has happened).

Bummed. This is the kind of game that takes over 20 hours or more to play all the way through and I know I've only really just started. But still. Annoying.
User avatar
Detroit, MI, USA

by Shot97 posted Fri Apr 21, 2017 3:33 pm

Curse is the shortest of the gold box games. As such, I've always felt it was kind of a let down for me personally.... Although the story is quite memorable. Now Silver Blades is both memorable and long, but long for all the wrong reasons. I believe I last played Curse via floppy, as it was before I had my hard drive. It ran (and saved) very fast from floppy, unlike Pool. So if you're having problems that wouldn't be the worst solution for you. I do have it on my hard drive now but I have not played it through. I think I may have finished it on my hard drive, I just had not started it there.

You could always transfer the files to PC and attempt that area via emulation, or transfer the saves to floppy and see if you can get past that area that way. The only issues I ever came upon were with transferring my party members from game to game, which could always be done but was also a pain.

- Can you elaborate on the bold text about a bug that made SSI decide to go floppy only? All the rest of the gold box games on the Amiga have a hard drive install minus maybe one (or both) of the Savage Frontier games. Those are my two favorite gold box games by the way. However, I have finished them both via hard drive and whichever one (or both) that did not feature an install program was fully capable of being installed manually, which I did. I'm not aware of them choosing to go floppy only.
User avatar
Seattle, WA, USA

by intric8 posted Fri Apr 21, 2017 4:58 pm

- Can you elaborate on the bold text about a bug that made SSI decide to go floppy only? All the rest of the gold box games on the Amiga have a hard drive install minus maybe one (or both) of the Savage Frontier games.

You know, you're right. I mis-spoke. I was thinking of the Gold Box game "Gateway to the Savage Frontier" which I received last weekend and installed. It was a completely baffling experience. SSI had decided at the last minute to remove all of the HD-Install icons from the Amiga version. But the only way a consumer knew this was by an info card they added to the insides of the box, thus negating all of the other instructions (also still in the box).

And my copy didn't have that info card about their decision to not make it HD Installable (due to RAM considerations). I also figured out how to get it all to HD and documented my steps, which I'll post later on when I feel it makes more sense to do so.

I'd like to really focus on Curse and get this issue behind me and just enjoy things. I confused the Savage RAM issue with Curse. Not enough coffee this morning I guess. :geek: Whatever is going on with Curse is really weird and a separate issue.

My thought this morning was to leave my HD install alone for now, but copy my SAVE to a save floppy disk. Play off the floppies, and load my current game and go from there. If everything seems OK, keep on truckin'. But maybe, after a few days or so, copy the Save file back to HD and see what happens.

I'd much rather just enjoy the game. But I don't really want to start over, either, unless I've got no other choice.

Tinkering! <3
User avatar
Detroit, MI, USA

by Shot97 posted Fri Apr 21, 2017 5:17 pm

I don't believe SSI ever bothered to port to the Amiga themselves, preferring to contract it out unlike Lucas Arts who did it by themselves. SSI never exactly went with a bad team, as even the lesser ports (like Curse) are still better than DOS if you look closely. The later games that had been done on VGA like Pools of Darkness of Dark Queen of Kyrnn, or Eye of the Beholder II could not be called "grade A" ports in my mind, as they featured much ditthering for example. But nor were they lazy, they still look incredible.... But with the two savage frontier titles you have an example of a game started on VGA that look perhaps better on the Amiga..

It just had everything to do with who ported it. So if indeed they had sort of given up on the hard drive with the Frontier games, it was not "SSI" that gave up, it was the company that ported it to the Amiga. I'd give them A+ grades on making it look just as if not more beautiful than the VGA original, but a big fat FAIL when it came to hard drive installers... Yeah, the reference card told me it could be installed.... But it's not there... I had to manually throw it over... Which just shows you that it can be done, RAM was probably a BS excuse... It's all in the company that ported it.
User avatar
Seattle, WA, USA

by intric8 posted Fri Apr 21, 2017 6:20 pm

What I've read is Frontier needs 512Kb chip, 512kb fast, and an extra 256kb (not much) when the HD was in use on top of WB. And that scared them off as they felt it would hurt overall sales.

So they stripped out the play icon and he installs so you could (for most folks) only play on boot.

Anyway the good news is (so far) Curse supports 2 floppy drives, so if I wind up playing off floppy it can hit both of mine without any swapping.


I should know more soon.
User avatar
Detroit, MI, USA

by Shot97 posted Fri Apr 21, 2017 8:12 pm

I believe there is still minor swapping, as Curse features two floppy disks plus you'll be needing a 3rd disk to save. If I recall you need to manually name the save disk something special. Though it might be that disk 1 is mostly just the intro and that the game plays largely off of disk 2. I just know my overall memories of Curse tell me it's pretty damn fast via floppy... Which was praised in reviews where as the first one was put down because of the loading times.... But the first one was something damn special in that it blew away every other version... Sigh, too bad they didn't think of the bigger picture... I mean honestly, Curse is not a straight DOS port when you look closely... But it could have looked so much better on the Amiga. And I bet the reviews of Pool of Radiance scared SSI into going with another company that ended up not giving its all, even if it's still the best version.... My biggest memory of Curse was the amount of time it took me to redo all my characters unique colors that I gave them in Pool when it came to transferring them to Curse. They looked so damn ugly, They possibly went from 32 colors in Pool down to 16 for Curse, or at least messed with the pallet quite a bit to where I spent just as much time if not more to make them look good in Curse.

So much stuff to think about when it comes to ports, and I'll say most people surely don't think about that stuff.
User avatar
Seattle, WA, USA

by intric8 posted Fri Apr 21, 2017 9:42 pm

I believe there is still minor swapping, as Curse features two floppy disks plus you'll be needing a 3rd disk to save.

Not with Curse. I have 2 internal floppy drives, as you know. And the game only has two disks. Amazingly, the original disks come with write/don't-write notches from the factory. They actually expected you to use your original disks for the Save files (which could hold 10 saves)! Amazing. Don't think I've EVER seen that before.

Regardless, I still copied the disks entirely to blanks and started playing off those tonight.

Then, I moved my Save file to my new working floppy (Disk A copy). It's just a Drawer that needs to be moved over.

Anyhoo... I started playing again tonight and I played for over half an hour this time. I made my way through the treacherous Thieves Guild which is filled with baddies.

Minor gripe: I do have to say, when the bad guys are beaten and start to "flee in panic" it is a major drag that you can't just end the battle right then and there. You have to either a) hope they run far enough off screen the game cuts you some slack (almost never), or b) go hunt them down and brutally kill them anyway (takes forever), or c) simply press "Q"uick, and let the computer take over your characters to go hunt them down and kill them. Still takes time, not to mention sometimes your characters go the wrong way and don't know how to go around walls correctly to finish the pursuit. Seems like there should just be a "end battle" option when it is painfully obvious who won that you could do or not do, ya know? But you only get that after everyone is REALLY far away or entirely dead. Gripe over. It's minor.

Anyway, after about 35 minutes of playing, right in the middle of a "Q"uick fight, where one of my characters had 5 more moves to go, the game just halted again while using floppies. Mouse still moves around the screen and everything seems OK. I don't even think the game was seeking the drive at the time. Would stake $1 million on that. Something in the code is just dying for some reason.

So, this seems to point to 1) either some weird software bug or corrupted routine or 2) some strange hardware failure/bug (like a RAM chip, or maybe CPU) that seems to only be occurring with this game. Really odd! I was hoping to play this game and give a review in about 3 weeks or so. Very sucky!

I guess I could go get some crap cracked ADFs out there as a final sanity test. Not sure what other option I've got really. The floppies installed to HD fine, and copied to other floppies fine with no issues. Really weird. It feels so random considering I played for over 1.5 hours (with a solid 1 hour stretch) the previous two days. And after crappy situations this morning, I thought I had gotten past it all then "Poof!" same crap.

In a way, I guess that's a good thing since it eliminates my hard drive as an issue, or the floppy drives. But damn!
User avatar
Detroit, MI, USA

by Shot97 posted Sat Apr 22, 2017 12:26 am

Oh I utterly hate the quick feature to put the computer in control of your characters. It's always such a pain to get them off it. I end up accidentally putting them on quick whenever I'm dealing with a character that can't "guard" due to their weapon and thus I must go to the other menu and click "quit" to end their turn... Only sometimes I hit Q when in the wrong menu. I've gone round after round attempting in vain to regain control of my characters as the computer wastes spell after spell or uses wands they have no business touching, putting my own characters into great danger. Oh no, micro management all the way for me.

If you're getting the same freezing issues from floppy then all I can tell you is I've never had the issues you've referred to, and I've beaten the game once from emulation, once from floppy, and finished once from hard drive. I would indeed be using a crack these days but I know my father beat it back in the day bought legit and he had all the gold box games... If he ran into such an issue I doubt he would have continued on.
User avatar
Seattle, WA, USA

by intric8 posted Sat Apr 22, 2017 7:45 am

I've gone round after round attempting in vain to regain control of my characters as the computer wastes spell after spell or uses wands they have no business touching, putting my own characters into great danger.
Ha! No doubt - it's moronic, but I am slapping my keyboard (the off switch) like a bongo player. I've only been using Quick whenever a finished battle just won't finish and I'm tired of clicking.

I've got some ADFs to swap over to disks to try. I have a bad feeling I'm going to see this issue again, but have no idea what's causing it. But I want to play it! I just finished the book this week. Super annoying. I guess I could drag the 1200 out of the closet, but I really love my 2000 and don't want to do that if I don't have to.

Who is online

Users browsing this forum: No registered users and 1 guest