Amiga hardware info, help and support with a focus (but not limited to) North American NTSC experiences. Open to all.
User avatar
santidarkg

Amiga 2500 Video slot issues

by santidarkg Tue Jul 03, 2018 1:41 pm

Hey guys...... my first post here :)

The last three months I have been building an Amiga 2500.

My dream was to install a few cards here and there and a Video Toaster.

First I did remove the Varta battery and cleaned the motherboard. After that I did install a Video Toaster A4000 version with the A2000 backplate.

My Amiga didnt see the board connected. I thought..... oh well, sometimes on ebay they sell Toasters broken. Or maybe it was my Amiga Video Slot.

So, I got a Toaster 2000 and I put there to try out.......and nothing, it doesnt show up :cry: :cry: :cry:

I have a DCTV too connected on the RGB port to see the AV signal in color. It doesnt show the AV signal either. I will try with my A1200 just to be sure if this DCTV works or not. It was a long time when I played with it.

Any ideas how I can test or find out if my A2500 video slot is busted ? There are two capacitors and maybe they need to be replaced, I dont know.

Thanks if you read this :)
User avatar
A10001986

Re: Amiga 2500 Video slot issues

by A10001986 Wed Jul 04, 2018 3:43 am

I never had a Video toaster, but I see from a quick google image search that it seems to plug into the video slot only.

If that assumption is correct, the Amiga isn't supposed to "see" the toaster; after all, the video slot is not a zorro slot, has no CPU busses and stuff.

In order to find out wether it works or not, the appropriate software will be required.
User avatar
Silverstreak

Re: Amiga 2500 Video slot issues

by Silverstreak Wed Jul 04, 2018 4:12 am

Hey, my first post too!

Is the 2500 a UK machine? Actually, wasn't it UK only? If so, read on, if not ignore :O)

In order to get a UK 2500 to work with the Toaster, you're going to need to do a bit of surgery...

The main part being the the replacement of the oscillator from a PAL to NTSC, this is surface mounted near Fat Agnus and not for the feint of heart!

Secondly a couple of dip switches need to be set; J102 for NTSC boot up (on my 2000 board this would have to be hard soldered) and J200 needs to be set for internal timing, which otherwise gets it's 'tick' from 50hz mains.

Then you should be good to go, I'm going to do this mod too so I'll let you know how I get on at some point! If there are errors here I can only apologise, I'm learning too.

Goodluck!
User avatar
santidarkg

Re: Amiga 2500 Video slot issues

by santidarkg Thu Jul 05, 2018 12:10 am

Thanks guys. My A2500 is NTSC and it was a dream 25 years ago to play with a Video Toaster so this is why I am building this new Beast.

Seems this jumper j300 is controlling 50/60 hz and it will affect the video signal (rgb 23 pins and Video Slot).

I will try this in the morning and I will let you know if this was the issue.. fingers crossed.

A10001986..... You dont need the software to verify is the card is recognized. Just holding the buttons of your mouse and checking the options in the boot menu you will see which hardware is connected.

Silverstreak...... let us know. I have a couple friends in Europe (I am in California now) very interested to play with a Video Toaster.

Thanks again.
User avatar
A10001986

Re: Amiga 2500 Video slot issues

by A10001986 Thu Jul 05, 2018 12:19 am

You won't see a card (only) connected to the video slot in the expansion list, that was my point.
User avatar
Silverstreak

Re: Amiga 2500 Video slot issues

by Silverstreak Thu Jul 05, 2018 2:12 am

Will do, thanks for the info! I always wanted a 2000, when I finally got one i'd forgotten how much of a tank it was! Haha.

I'll let you know my (gradual) process, best of luck.
User avatar
santidarkg

Re: Amiga 2500 Video slot issues

by santidarkg Thu Jul 05, 2018 8:04 am

ok guys, jumped the J300 and nothing, didnt show the video toaster.

arghhh :(.

Any more ideas before I find somebody to check the hardware ?

thanks again.

Forgot to say that I am using a Vampire V500 v2+.... I going to try the original 68k again and see if I can see in the boot menu my toaster.
User avatar
Silverstreak

Re: Amiga 2500 Video slot issues

by Silverstreak Thu Jul 05, 2018 12:15 pm

Well that’s interesting, I would LOVE to know if the vampire worked with the toaster. As would you, I know.

There is a guy on YouTube doing cool lightwave stuff with a toaster and a vampire, but he’s not using the switcher. That’s a good point, does lightwave fire up?
User avatar
santidarkg

Re: Amiga 2500 Video slot issues

by santidarkg Thu Jul 05, 2018 12:40 pm

Yes, Lightwave works without any problem. Previews are faster than 060 of course and in general, everything that I tried to play with Vampire is working so far.

Best board ever made for Amiga.

Ok, time to swap the 68k and ROM.

:)
User avatar
pedalpowered

Re: Amiga 2500 Video slot issues

by pedalpowered Fri Sep 28, 2018 3:38 pm

Have you gotten your Vampire to work with the other Toaster software yet? I'm very anxious to find out, as that's the main reason I want an accelerator, and a Vampire is the best accelerator going now.

Edit: My first post, too! I guess the Toaster is a hot topic. ;)

Who is online

Users browsing this forum: No registered users and 3 guests